Some users may be unable to access multiple Microsoft 365 services

Incident Report for Cal Poly ITS Systems

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 10:29 PST

Monitoring

We've received reports that the issue is no longer occurring for some users and we're continuing our investigation to confirm full recovery. Our investigation is focused on content delivery network (CDN) configurations and interactions with third‑party network providers.
Posted Mar 06, 2026 - 09:42 PST

Investigating

Service outages reported by Microsoft this morning. ITS teams are currently investigating and will send updates.
Posted Mar 06, 2026 - 08:41 PST
This incident affected: Office 365.